De-Humidstat installation

» Site Navigation
Home Page The Villages Maps The Villages Activities The Villages Clubs The Villages Book Healthcare Rentals Real Estate Section Classified Section The Villages Directory Home Improvement Site Guidelines Advertising Info Register Now Video Tutorials Frequently Asked Questions
» Newsletter Signup
» Premium Tower
» Advertisements
» Trending News
» Tower Sponsors




















» Premium Sponsors
» Banner Sponsors
» Advertisements
Closed Thread
Thread Tools
  #1  
Old 01-12-2015, 07:30 PM
kpdandjad kpdandjad is offline
Junior Member
Join Date: Oct 2013
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default De-Humidstat installation

I installed a Honeywell De-Humidstat in series with the A/C. Since we are snowbirds, I wanted to give it a test run and discovered a problem: the A/C will run normally until the lower humidity gets to the set point of the de-humidistat. At that point the A/C compressor and condenser fan turns off as expected, but the evaporator fan continues to run and will not stop until the inside temperature reaches the thermostat set point. If this happened during the summer, the fan would be running most of the time!
Any ideas on what changes I need to make to the wiring? All I did was insert the De-Humidstat in series with the yellow wire, It is a new Carrier Heat Pump with an Edge Thermostat.
Closed Thread

Thread Tools

You are viewing a new design of the TOTV site. Click here to revert to the old version.

All times are GMT -5. The time now is 05:46 AM.